using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(VI[0-9]{4}(?:BV)?(?:\d{2})?(D|H|MIN|MAX)?)+$";
string input = @"6789
VI2111
VI2122
VI2122MIN
VI2122MAX
VI2122MUN
VI210021
VI210021D
VI210021H
VI210021X
VI2100BVMIN
VI2100BVMAX
VI2100
VI21001";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}