const regex = /^(VI[0-9]{4}(?:BV)?(?:\d{2})?(D|H|MIN|MAX)?)+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(VI[0-9]{4}(?:BV)?(?:\\d{2})?(D|H|MIN|MAX)?)+$', 'gm')
const str = `6789
VI2111
VI2122
VI2122MIN
VI2122MAX
VI2122MUN
VI210021
VI210021D
VI210021H
VI210021X
VI2100BVMIN
VI2100BVMAX
VI2100
VI21001`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}