import Foundation
let pattern = #"(?<Street>\d.+(?:court|ct|street|st|drive|dr|lane|ln|road|rd|blvd))(?:,\W*)((?<Suite>\w.+?)(?:,\W*))?(?<City>\w.+?)(?:,\W*)(?<State>[a-z]+)(?:\W*)(?<Zipcode>\d{5})"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
39 w. 38th Street, 10th Floor, NY, NY 10018
39 w. 38th Street, NY, NY 10018
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$<Street>|$<Suite>|$<Sity>|$<State>|$<Zipcode>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)