# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<Street>\d.+(?:court|ct|street|st|drive|dr|lane|ln|road|rd|blvd))(?:,\W*)((?<Suite>\w.+?)(?:,\W*))?(?<City>\w.+?)(?:,\W*)(?<State>[a-z]+)(?:\W*)(?<Zipcode>\d{5})/$<Street>|$<Suite>|$<Sity>|$<State>|$<Zipcode>/gmi;t' <<< "39 w. 38th Street, 10th Floor, NY, NY 10018
39 w. 38th Street, NY, NY 10018"