import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<Street>\\d.+(?:court|ct|street|st|drive|dr|lane|ln|road|rd|blvd))(?:,\\W*)((?<Suite>\\w.+?)(?:,\\W*))?(?<City>\\w.+?)(?:,\\W*)(?<State>[a-z]+)(?:\\W*)(?<Zipcode>\\d{5})";
final String string = "39 w. 38th Street, 10th Floor, NY, NY 10018\n"
+ "39 w. 38th Street, NY, NY 10018";
final String subst = "$<Street>|$<Suite>|$<Sity>|$<State>|$<Zipcode>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}