const regex = /(?<Street>\d.+(?:court|ct|street|st|drive|dr|lane|ln|road|rd|blvd))(?:,\W*)((?<Suite>\w.+?)(?:,\W*))?(?<City>\w.+?)(?:,\W*)(?<State>[a-z]+)(?:\W*)(?<Zipcode>\d{5})/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<Street>\\d.+(?:court|ct|street|st|drive|dr|lane|ln|road|rd|blvd))(?:,\\W*)((?<Suite>\\w.+?)(?:,\\W*))?(?<City>\\w.+?)(?:,\\W*)(?<State>[a-z]+)(?:\\W*)(?<Zipcode>\\d{5})', 'gmi')
const str = `39 w. 38th Street, 10th Floor, NY, NY 10018
39 w. 38th Street, NY, NY 10018`;
const subst = `$<Street>|$<Suite>|$<Sity>|$<State>|$<Zipcode>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);