use strict;
my $str = '39 w. 38th Street, 10th Floor, NY, NY 10018
39 w. 38th Street, NY, NY 10018';
my $regex = qr/(?<Street>\d.+(?:court|ct|street|st|drive|dr|lane|ln|road|rd|blvd))(?:,\W*)((?<Suite>\w.+?)(?:,\W*))?(?<City>\w.+?)(?:,\W*)(?<State>[a-z]+)(?:\W*)(?<Zipcode>\d{5})/mip;
my $subst = '$<Street>|$<Suite>|$<Sity>|$<State>|$<Zipcode>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";