$re = '/(?<Street>\d.+(?:court|ct|street|st|drive|dr|lane|ln|road|rd|blvd))(?:,\W*)((?<Suite>\w.+?)(?:,\W*))?(?<City>\w.+?)(?:,\W*)(?<State>[a-z]+)(?:\W*)(?<Zipcode>\d{5})/mi';
$str = '39 w. 38th Street, 10th Floor, NY, NY 10018
39 w. 38th Street, NY, NY 10018';
$subst = "$<Street>|$<Suite>|$<Sity>|$<State>|$<Zipcode>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;