$re = '/^http(?:s?):\/\/regex101\.com\/r\/([a-zA-Z0-9]{1,6})?$/m';
$str = 'http://regex101.com/r/mH1fN5
http://regex101.com/r/fW0vZ2';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;