using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http(?:s?):\/\/regex101\.com\/r\/([a-zA-Z0-9]{1,6})?$";
string substitution = @"";
string input = @"http://regex101.com/r/mH1fN5
http://regex101.com/r/fW0vZ2";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}