const regex = /^http(?:s?):\/\/regex101\.com\/r\/([a-zA-Z0-9]{1,6})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^http(?:s?):\\\/\\\/regex101\\.com\\\/r\\\/([a-zA-Z0-9]{1,6})?$', 'gm')
const str = `http://regex101.com/r/mH1fN5
http://regex101.com/r/fW0vZ2`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);