#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^http(?:s?):\/\/regex101\.com\/r\/([a-zA-Z0-9]{1,6})?$"
Local $sString = "http://regex101.com/r/mH1fN5" & @CRLF & _
"http://regex101.com/r/fW0vZ2"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)