import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^http(?:s?):\\/\\/regex101\\.com\\/r\\/([a-zA-Z0-9]{1,6})?$";
final String string = "http://regex101.com/r/mH1fN5\n"
+ "http://regex101.com/r/fW0vZ2";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}