# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^http(?:s?):\\/\\/regex101\.com\\/r\\/([a-zA-Z0-9]{1,6})?$//gm;t' <<< "http://regex101.com/r/mH1fN5
http://regex101.com/r/fW0vZ2"