import Foundation
let pattern = #"(TRACE(\s*)\(\S+\s*[,](\s*\S+\s*)[,\n](\s*\S+\s*)[,](\s*))([^\"])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
TRACE(&logger_mr , DEBUG_2 , NULL ,
UdpPathMgmtLogger::entranceStr_sc;
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 "%s" \6"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)