use strict;
my $str = 'TRACE(&logger_mr , DEBUG_2 , NULL ,
UdpPathMgmtLogger::entranceStr_sc;
';
my $regex = qr/(TRACE(\s*)\(\S+\s*[,](\s*\S+\s*)[,\n](\s*\S+\s*)[,](\s*))([^\"])/mp;
my $subst = '\\1 "%s" \\6';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";