$re = '/(TRACE(\s*)\(\S+\s*[,](\s*\S+\s*)[,\n](\s*\S+\s*)[,](\s*))([^\"])/m';
$str = 'TRACE(&logger_mr , DEBUG_2 , NULL ,
UdpPathMgmtLogger::entranceStr_sc;
';
$subst = "\1 \"%s\" \6";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;