re = /(TRACE(\s*)\(\S+\s*[,](\s*\S+\s*)[,\n](\s*\S+\s*)[,](\s*))([^\"])/m
str = 'TRACE(&logger_mr , DEBUG_2 , NULL ,
UdpPathMgmtLogger::entranceStr_sc;
'
subst = '\\1 "%s" \\6'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result