using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(TRACE(\s*)\(\S+\s*[,](\s*\S+\s*)[,\n](\s*\S+\s*)[,](\s*))([^\""])";
string substitution = @"\1 ""%s"" \6";
string input = @"TRACE(&logger_mr , DEBUG_2 , NULL ,
UdpPathMgmtLogger::entranceStr_sc;
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}