package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(TRACE(\s*)\(\S+\s*[,](\s*\S+\s*)[,\n](\s*\S+\s*)[,](\s*))([^\"])`)
var str = `TRACE(&logger_mr , DEBUG_2 , NULL ,
UdpPathMgmtLogger::entranceStr_sc;
`
var substitution = "\1 "%s" \6"
fmt.Println(re.ReplaceAllString(str, substitution))
}