re = /^(feature|chore|fix|security|wip)\/[A-Z0-9]+-[0-9]+[A-Za-z0-9|_|-]+$/m
str = 'feature/NSPS2-1284_update-validation
feature/NSPS2-1277_AValidBranchName
chore/NSPS2-1277_AValidBranchName
fix/NSPS2-1277_AValidBranchName
security/NSPS2-1277_AValidBranchName
wip/NSPS2-1277_AValidBranchName'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end