$re = '/^(feature|chore|fix|security|wip)\/[A-Z0-9]+-[0-9]+[A-Za-z0-9|_|-]+$/m';
$str = 'feature/NSPS2-1284_update-validation
feature/NSPS2-1277_AValidBranchName
chore/NSPS2-1277_AValidBranchName
fix/NSPS2-1277_AValidBranchName
security/NSPS2-1277_AValidBranchName
wip/NSPS2-1277_AValidBranchName';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);