const regex = /^(feature|chore|fix|security|wip)\/[A-Z0-9]+-[0-9]+[A-Za-z0-9|_|-]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(feature|chore|fix|security|wip)\\\/[A-Z0-9]+-[0-9]+[A-Za-z0-9|_|-]+$', 'gm')
const str = `feature/NSPS2-1284_update-validation
feature/NSPS2-1277_AValidBranchName
chore/NSPS2-1277_AValidBranchName
fix/NSPS2-1277_AValidBranchName
security/NSPS2-1277_AValidBranchName
wip/NSPS2-1277_AValidBranchName`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}