#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(feature|chore|fix|security|wip)\/[A-Z0-9]+-[0-9]+[A-Za-z0-9|_|-]+$"
Local $sString = "feature/NSPS2-1284_update-validation" & @CRLF & _
"feature/NSPS2-1277_AValidBranchName" & @CRLF & _
"chore/NSPS2-1277_AValidBranchName" & @CRLF & _
"fix/NSPS2-1277_AValidBranchName" & @CRLF & _
"security/NSPS2-1277_AValidBranchName" & @CRLF & _
"wip/NSPS2-1277_AValidBranchName"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")