package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(feature|chore|fix|security|wip)\/[A-Z0-9]+-[0-9]+[A-Za-z0-9|_|-]+$`)
var str = `feature/NSPS2-1284_update-validation
feature/NSPS2-1277_AValidBranchName
chore/NSPS2-1277_AValidBranchName
fix/NSPS2-1277_AValidBranchName
security/NSPS2-1277_AValidBranchName
wip/NSPS2-1277_AValidBranchName`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}