import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(feature|chore|fix|security|wip)\\/[A-Z0-9]+-[0-9]+[A-Za-z0-9|_|-]+$";
final String string = "feature/NSPS2-1284_update-validation\n"
+ "feature/NSPS2-1277_AValidBranchName\n"
+ "chore/NSPS2-1277_AValidBranchName\n"
+ "fix/NSPS2-1277_AValidBranchName\n"
+ "security/NSPS2-1277_AValidBranchName\n"
+ "wip/NSPS2-1277_AValidBranchName";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}