$re = '/^(?=.*[а-я])(?=.*[А-Я])[а-яА-Я]+$/m';
$str = 'qwerty1
QWERTY1q
qwERTy
QWERTY1
QWER TY1q
Мама
авТо
гриБ
Яблоко
яБлоко
ябЛоко
яблОко
яблоКо
яблокО
агент007
стриж
ГТО
Три богатыря';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;