#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?=.*[а-я])(?=.*[А-Я])[а-яА-Я]+$"
Local $sString = "qwerty1" & @CRLF & _
"QWERTY1q" & @CRLF & _
"qwERTy" & @CRLF & _
"QWERTY1" & @CRLF & _
"QWER TY1q" & @CRLF & _
"" & @CRLF & _
"Мама" & @CRLF & _
"авТо" & @CRLF & _
"гриБ" & @CRLF & _
"Яблоко" & @CRLF & _
"яБлоко" & @CRLF & _
"ябЛоко" & @CRLF & _
"яблОко" & @CRLF & _
"яблоКо" & @CRLF & _
"яблокО" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"агент007" & @CRLF & _
"стриж" & @CRLF & _
"ГТО" & @CRLF & _
"Три богатыря"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)