import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[а-я])(?=.*[А-Я])[а-яА-Я]+$";
final String string = "qwerty1\n"
+ "QWERTY1q\n"
+ "qwERTy\n"
+ "QWERTY1\n"
+ "QWER TY1q\n\n"
+ "Мама\n"
+ "авТо\n"
+ "гриБ\n"
+ "Яблоко\n"
+ "яБлоко\n"
+ "ябЛоко\n"
+ "яблОко\n"
+ "яблоКо\n"
+ "яблокО\n\n\n"
+ "агент007\n"
+ "стриж\n"
+ "ГТО\n"
+ "Три богатыря";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}