using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.*[а-я])(?=.*[А-Я])[а-яА-Я]+$";
string substitution = @"";
string input = @"qwerty1
QWERTY1q
qwERTy
QWERTY1
QWER TY1q
Мама
авТо
гриБ
Яблоко
яБлоко
ябЛоко
яблОко
яблоКо
яблокО
агент007
стриж
ГТО
Три богатыря";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}