const regex = /^(?=.*[а-я])(?=.*[А-Я])[а-яА-Я]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.*[а-я])(?=.*[А-Я])[а-яА-Я]+$', 'gm')
const str = `qwerty1
QWERTY1q
qwERTy
QWERTY1
QWER TY1q
Мама
авТо
гриБ
Яблоко
яБлоко
ябЛоко
яблОко
яблоКо
яблокО
агент007
стриж
ГТО
Три богатыря`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);