re = /==========\nFind Your Why \(Simon Sinek;David Mead;Peter Docker\)\n- Your Highlight on Location (.*)/
str = '==========
Find Your Why (Simon Sinek;David Mead;Peter Docker)
- Your Highlight on Location 77-78 | Added on Sunday, March 11, 2018 5:35:40 PM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end