package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`==========\nFind Your Why \(Simon Sinek;David Mead;Peter Docker\)\n- Your Highlight on Location (.*)`)
var str = `==========
Find Your Why (Simon Sinek;David Mead;Peter Docker)
- Your Highlight on Location 77-78 | Added on Sunday, March 11, 2018 5:35:40 PM`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}