use strict;
my $str = '==========
Find Your Why (Simon Sinek;David Mead;Peter Docker)
- Your Highlight on Location 77-78 | Added on Sunday, March 11, 2018 5:35:40 PM';
my $regex = qr/==========\nFind Your Why \(Simon Sinek;David Mead;Peter Docker\)\n- Your Highlight on Location (.*)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}