$re = '/==========\nFind Your Why \(Simon Sinek;David Mead;Peter Docker\)\n- Your Highlight on Location (.*)/';
$str = '==========
Find Your Why (Simon Sinek;David Mead;Peter Docker)
- Your Highlight on Location 77-78 | Added on Sunday, March 11, 2018 5:35:40 PM';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);