import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "==========\\nFind Your Why \\(Simon Sinek;David Mead;Peter Docker\\)\\n- Your Highlight on Location (.*)";
final String string = "==========\n"
+ "Find Your Why (Simon Sinek;David Mead;Peter Docker)\n"
+ "- Your Highlight on Location 77-78 | Added on Sunday, March 11, 2018 5:35:40 PM";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}