const regex = /==========\nFind Your Why \(Simon Sinek;David Mead;Peter Docker\)\n- Your Highlight on Location (.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('==========\\nFind Your Why \\(Simon Sinek;David Mead;Peter Docker\\)\\n- Your Highlight on Location (.*)', 'g')
const str = `==========
Find Your Why (Simon Sinek;David Mead;Peter Docker)
- Your Highlight on Location 77-78 | Added on Sunday, March 11, 2018 5:35:40 PM`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}