import Foundation
let pattern = #"(?<=\D)(?=\d)|(?<=\d)(?=\D)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
a3:2bc/12.3\efg;123.12a:5,|i(+/-)j.
BENZENEACETIC ACID, .ALPHA.-HYDROXY-, (+/-)-, COMPD. WITH 1,3,5,7-TETRAAZATRICYCLO((3.3.1.1(SUP 3,7))DECANE (1:1)
Text
ibuprofen
ibuprofen;
ibuprofen.
ibuprofen:
ibuprofen(Ibumetin)
ibuprofen,enalapril
ibuprofen|enalapril
:ibuprofen
-ibumetin,
ibuprofen/enalapril
ibuprofen / enalapril
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)