re = /(?<=\D)(?=\d)|(?<=\d)(?=\D)/m
str = 'a3:2bc/12.3\\efg;123.12a:5,|i(+/-)j.
BENZENEACETIC ACID, .ALPHA.-HYDROXY-, (+/-)-, COMPD. WITH 1,3,5,7-TETRAAZATRICYCLO((3.3.1.1(SUP 3,7))DECANE (1:1)
Text
ibuprofen
ibuprofen;
ibuprofen.
ibuprofen:
ibuprofen(Ibumetin)
ibuprofen,enalapril
ibuprofen|enalapril
:ibuprofen
-ibumetin,
ibuprofen/enalapril
ibuprofen / enalapril
'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result