# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\D)(?=\d)|(?<=\d)(?=\D)"
test_str = ("a3:2bc/12.3\\efg;123.12a:5,|i(+/-)j.\n"
"BENZENEACETIC ACID, .ALPHA.-HYDROXY-, (+/-)-, COMPD. WITH 1,3,5,7-TETRAAZATRICYCLO((3.3.1.1(SUP 3,7))DECANE (1:1)\n"
"Text\n"
"ibuprofen\n"
"ibuprofen;\n"
"ibuprofen.\n"
"ibuprofen:\n"
"ibuprofen(Ibumetin)\n"
"ibuprofen,enalapril\n"
"ibuprofen|enalapril\n"
":ibuprofen\n"
"-ibumetin,\n"
"ibuprofen/enalapril\n"
"ibuprofen / enalapril\n")
subst = " "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.