import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\D)(?=\\d)|(?<=\\d)(?=\\D)";
final String string = "a3:2bc/12.3\\efg;123.12a:5,|i(+/-)j.\n"
+ "BENZENEACETIC ACID, .ALPHA.-HYDROXY-, (+/-)-, COMPD. WITH 1,3,5,7-TETRAAZATRICYCLO((3.3.1.1(SUP 3,7))DECANE (1:1)\n"
+ "Text\n"
+ "ibuprofen\n"
+ "ibuprofen;\n"
+ "ibuprofen.\n"
+ "ibuprofen:\n"
+ "ibuprofen(Ibumetin)\n"
+ "ibuprofen,enalapril\n"
+ "ibuprofen|enalapril\n"
+ ":ibuprofen\n"
+ "-ibumetin,\n"
+ "ibuprofen/enalapril\n"
+ "ibuprofen / enalapril\n";
final String subst = " ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}