#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=\D)(?=\d)|(?<=\d)(?=\D)"
Local $sString = "a3:2bc/12.3\efg;123.12a:5,|i(+/-)j." & @CRLF & _
"BENZENEACETIC ACID, .ALPHA.-HYDROXY-, (+/-)-, COMPD. WITH 1,3,5,7-TETRAAZATRICYCLO((3.3.1.1(SUP 3,7))DECANE (1:1)" & @CRLF & _
"Text" & @CRLF & _
"ibuprofen" & @CRLF & _
"ibuprofen;" & @CRLF & _
"ibuprofen." & @CRLF & _
"ibuprofen:" & @CRLF & _
"ibuprofen(Ibumetin)" & @CRLF & _
"ibuprofen,enalapril" & @CRLF & _
"ibuprofen|enalapril" & @CRLF & _
":ibuprofen" & @CRLF & _
"-ibumetin," & @CRLF & _
"ibuprofen/enalapril" & @CRLF & _
"ibuprofen / enalapril" & @CRLF & _
""
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)