// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(Bind off) (\d+) (\(\d+)(( \: \d+){0,8}) (\) M)").unwrap();
let string = "Bind off 3 (6 : 8 : 8 : 10 ) M
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}