package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(Bind off) (\d+) (\(\d+)(( \: \d+){0,8}) (\) M)`)
var str = `Bind off 3 (6 : 8 : 8 : 10 ) M
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}