using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(Bind off) (\d+) (\(\d+)(( \: \d+){0,8}) (\) M)";
string input = @"Bind off 3 (6 : 8 : 8 : 10 ) M
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}