$re = '/(Bind off) (\d+) (\(\d+)(( \: \d+){0,8}) (\) M)/m';
$str = 'Bind off 3 (6 : 8 : 8 : 10 ) M
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);