re = /(Bind off) (\d+) (\(\d+)(( \: \d+){0,8}) (\) M)/m
str = 'Bind off 3 (6 : 8 : 8 : 10 ) M
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end