const regex = /(Bind off) (\d+) (\(\d+)(( \: \d+){0,8}) (\) M)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(Bind off) (\\d+) (\\(\\d+)(( \\: \\d+){0,8}) (\\) M)', 'gm')
const str = `Bind off 3 (6 : 8 : 8 : 10 ) M
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}