use strict;
my $str = 'heading 1 0. References
heading 1 1. Introduction
heading 1 2. System of interest: heavy component
heading 2 2.1 Definition and role of the heavy component
heading 3 2.1.1 General Definitions
heading 3 2.1.2 heavy component main missions
heading 11 2.1.1.11.3.4 Generic chapter
';
my $regex = qr/^[Hh]eading\t(\d+)\t[\d\.]+\t(.+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}