using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[Hh]eading\t(\d+)\t[\d\.]+\t(.+)";
string input = @"heading 1 0. References
heading 1 1. Introduction
heading 1 2. System of interest: heavy component
heading 2 2.1 Definition and role of the heavy component
heading 3 2.1.1 General Definitions
heading 3 2.1.2 heavy component main missions
heading 11 2.1.1.11.3.4 Generic chapter
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}